Recent Posts

Pages: [1] 2
1
Support sur le logiciel JustConsum / Nouvelle version 1.2.1 de JustConsum
« Last post by kredge on 20 December 2019 à 19:50:37 »
La nouvelle version 1.2.1 corrige 2 problèmes :

- problème majeur :
si la période entre 2 relevés de consommation était approxivement de 1 heure : alors le logiciel se bloquait.
Donc à présent, le blocage est résolu.

- problème mineur :
lors de la génération en PDF du relevé de consommation : la période indiquée sur le relevé était erronée sur la partie "minutes" indiquée, alors qu'elle était correcte dans le logiciel (la durée ne corespondait pas)
Ce bug d'affichage est résolu.  ;)
2
Soporte del software JustConsum / Nueva versión 1.2.1 de JustConsum
« Last post by kredge on 20 December 2019 à 19:48:58 »
La nueva versión 1.2.1 soluciona 2 problemas :

- un problema importante :
si el período entre 2 lecturas de consumo fuera de aproximadamente 1 hora : entonces el software se bloqueaba.
Así que ahora el bloqueo está resuelto.

- problema menor :
durante la generación del fichero de consumo en formato PDF : el período indicado en la declaración era incorrecto en la parte de "minutos" indicada, mientras que era correcto en el software (la duración no coincidía)
Este error de visualización está resuelto.  ;)
3
Support for JustConsum software / New version 1.2.1 of JustConsum
« Last post by kredge on 20 December 2019 à 19:48:09 »
New version 1.2.1 fixes 2 problems :

- major problem :
if the period between 2 consumption readings was approximately 1 hour: then the software was blocked.
Since now the blocking is solved.

- minor problem:
when generating the consumption statement in PDF : the period indicated on the statement was incorrect on the "minutes" section indicated, whereas it was correct in the software (the duration did not match)
This display bug is solved.  ;)
4
Soporte del software JustConsum / Nueva versión 1.2 de JustConsum
« Last post by kredge on 22 October 2019 à 15:20:29 »
Esta versión 1.2 agrega una opción para combinar años al comparar múltiples curvas.
Para superponer varios años diferentes en el mismo gráfico.

Por ejemplo, para obtener que las curvas de 3 informes de 3 años diferentes (informe de 2016, informe de 2017, informe de 2018), estén representados en un mismo período de forma "superpuesta", para poder compararlos en el mismo período "fuera de un año en particular".



5
Support for JustConsum software / New version 1.2 of JustConsum
« Last post by kredge on 22 October 2019 à 15:19:57 »
This version 1.2 adds an option to merge years when comparing multiple curves.
In order to superimpose several different years in the same graph.

For example, to have the curves of 3 readings of 3 different years (2016 reading, 2017 reading, 2018 reading), be represented over the same period in a "superimposed" way, so that they can be compared over the same period "in outside of a particular year".



6
Support sur le logiciel JustConsum / Nouvelle version 1.2 de JustConsum
« Last post by kredge on 22 October 2019 à 15:15:42 »
Cette version 1.2 ajoute une option pour fusionner les années lors de la comparaison de plusieurs courbes.
De façon à pouvoir superposer plusieurs années différentes dans un même graphique.

Par exemple, obtenir que les courbes de 3 relevés de 3 années différentes (relevé sur 2016, relevé sur 2017, relevé sur 2018), soit représenté sur une même période de façon "superposées", pour pouvoir les comparer sur une même période "en dehors d'une année particulière".



7
Important :
if there is a problem launching the software under OpenMandriva Lx 4.0, if you get an error of the type :

[kredge@OpenMandriva4 JustConsum]$ ./JustConsum
** (JustConsum:2409): ERROR **: 21:32:50.318: Unable to fork a new child process: Failed to execute child process “/usr/libexec/webkit2gtk-4.0/WebKitWebProcess” (No such file or directory)
Trace/breakpoint trap (core dumped)
[redge@OpenMandriva4 JustConsum]$

So you have to install the package :
lib64webkit2gtk4.0_37 - GTK+ port of WebKit web browser engine

as well as its dependencies ...
8
Importante:
si hay un problema al iniciar el software en OpenMandriva Lx 4.0, si obtiene un error del tipo :

[kredge@OpenMandriva4 JustConsum]$ ./JustConsum
** (JustConsum:2409): ERROR **: 21:32:50.318: Unable to fork a new child process: Failed to execute child process “/usr/libexec/webkit2gtk-4.0/WebKitWebProcess” (No such file or directory)
Trace/breakpoint trap (core dumped)
[redge@OpenMandriva4 JustConsum]$

Entonces Usted tiene que instalar el paquete :
lib64webkit2gtk4.0_37 - GTK+ port of WebKit web browser engine

así que sus dependencias ...
9
Important :
en cas de problème de lancement du logiciel sous OpenMandriva Lx 4.0, si vous obtenez une erreur du type :

[kredge@OpenMandriva4 JustConsum]$ ./JustConsum
** (JustConsum:2409): ERROR **: 21:32:50.318: Unable to fork a new child process: Failed to execute child process “/usr/libexec/webkit2gtk-4.0/WebKitWebProcess” (No such file or directory)
Trace/breakpoint trap (core dumped)
[redge@OpenMandriva4 JustConsum]$

Alors il vous faut installer le paquet :
lib64webkit2gtk4.0_37 - GTK+ port of WebKit web browser engine

ainsi que ses dépendances...
10
En los sistemas Debian, Ubuntu o Mint, es posible que JustConsum no pueda abrir archivos PDF directamente (utilizado en el software para ediciones de la lista de los informes y también para los detalles de un informe).
El software no parece ser capaz de abrir el documento PDF.....
Una primera solución sería guardar primero el archivo en el disco duro, luego abrirlo fuera de JustConsum: entonces verás el contenido del archivo apparecer en pantalla.

Pero el problema podría ser simplemente un bloqueo del sistema Linux:
Puede ser "AppArmor" que impide que el lector de PDF "Evince" abra el archivo generado por JustConsum.

Así es como se arregla esto:

En modo "root", ejecute primero el comando: "apparmor_status".
Deberías tener una respuesta como:

Code: [Select]
    root@brix:~# apparmor_status
    apparmor module is loaded.
    14 profiles are loaded.
    14 profiles are in enforce mode.
    /usr/bin/evince

A continuación, compruebe que la herramienta "apparmor-utils" está bien instalada:
en caso de duda, ejecute el comando, de nuevo en modo "root", "apt-get install apparmor-utils".

Luego ejecutar en modo "root" de nuevo "aa-complain /usr/bin/evince".
Obtendrá una respuesta como esta:

Code: [Select]
    root@brix:~# aa-complain /usr/bin/evince
    Setting /usr/bin/bin/evince to complain mode.

Para comprobar si la protección "apparmor" ha funcionado correctamente, vuelva a ejecutarla en modo "root": "apparmor_status".
Deberías tener una respuesta como:

Code: [Select]
    root@brix:/etc# apparmor_status
    apparmor module is loaded.
    14 profiles are loaded.
    11 profiles are in enforce mode.

Esta operación permite lanzar con éxito el visor "Evince" del sistema, desde el software JustConsum.

Para más información sobre el desbloqueo de "Evince":
https://askubuntu.com/questions/486150/evince-error-while-loading-shared-libraries-permission-denied
https://help.ubuntu.com/community/AppArmor
Pages: [1] 2